develooper Front page | perl.perl5.porters | Postings from September 2017

[perl #129916] CV symbol table optimization only works in main::

Thread Previous | Thread Next
From:
Atoomic via RT
Date:
September 25, 2017 15:13
Subject:
[perl #129916] CV symbol table optimization only works in main::
Message ID:
rt-4.0.24-31949-1506352409-546.129916-15-0@perl.org
On Sun, 24 Sep 2017 14:34:35 -0700, sprout wrote:
> On Thu, 21 Sep 2017 16:22:55 -0700, atoomic wrote:
> > In addition to my previous emaul, you would found attached to this
> > message a minor update of the multideref patch which uses 'sv'
> > instead
> > of '*svp'.
> >
> > After running the tests from 'sprout/cv-in-stash' with this
> > additional
> > patch only 3 tests fail:
> >         ../ext/B/t/xref.t
> >         ../ext/XS-APItest/t/gv_fetchmeth.t
> >         ../lib/B/Deparse.t
> 
> I have fixed the last two.  They are now passing for me locally.
> 
> >
> > I've attached a fix for the B::Xref one,
> 
> But I am not getting that failure.  What is your perl configuration?
> Mine:
> 
> $ ./perl -Ilib -V:config_args
> config_args='-de -DDEBUGGING -Dusedevel -Duseithreads -Doptimize=-O0
> -Aoptimize=-g -Accflags=-DPERL_BOOL_AS_CHAR -Dcc=g++ -Accflags=-
> DPERL_POISON';

I was simply running configure with: ./Configure -Dusedevel -Doptimize=-g3 -des


---
via perlbug:  queue: perl5 status: open
https://rt.perl.org/Ticket/Display.html?id=129916

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About