develooper Front page | perl.perl5.porters | Postings from July 2017

Re: [perl #131685] Rename utf8::is_utf8() (and other functions)

Thread Previous | Thread Next
Sawyer X
July 10, 2017 16:46
Re: [perl #131685] Rename utf8::is_utf8() (and other functions)
Message ID:

On 07/04/2017 07:38 AM, wrote:
> On Tuesday 04 July 2017 13:32:26 demerphq wrote:
>> It is only unpredictable if your model of strings is broken.
> I do not know what you mean if model of strings is broken,

It is "broken" in that sense for probably more people than we would
like. Do we have any documentation that clarifies this entire issue?
(I know I trip on this frequently and never fully understood this issue

> [...]
>> I happen
>> to be very familiar with the internals, and do not find the actual
>> rules to be that difficult to deal with.
> I think this discussion is out of original request, which is for better
> documentation of and better name for utf8::is_utf8() function.


For now we seem to have two points we agree on:
* We want to document these functions
* We want to give them better names
* We want the old behavior to work

As long as the second clause does not break the third, I think we should
seek to move forward.

Yves mentioned that "Internals" namespace to be undesired place for it
(which was discussed at P5H, the last core hackathon) and I agree.
"scalar" was the most popular one, IIRC.

Does anyone have any comments on this? Tony, Dave, Zefram? *Karl*? :)


Thread Previous | Thread Next Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at | Group listing | About