develooper Front page | perl.perl5.porters | Postings from March 2017

Re: Proposal: Rename utf8::is_utf8() to utf8::is_upgraded()

Thread Previous | Thread Next
March 5, 2017 12:29
Re: Proposal: Rename utf8::is_utf8() to utf8::is_upgraded()
Message ID:
On Saturday 25 February 2017 23:10:24 Karl Williamson wrote:
> On 02/19/2017 11:41 AM, Father Chrysostomos wrote:
> >Karl Williamson wrote:
> >>So, I support adding a synonym.
> >
> >I do not.  The main reasons for using the function are to work around
> >problems with buggy XS modules.  Adding a synonym for a function that
> >most correct code should not be using seems like the wrong direction
> >to be going in.
> >
> I don't think your argument makes sense here.  Having a name that clearly
> indicates what the function does will decrease the likelihood of someone
> using it in situations where it isn't warranted, which is what we want.

+1. Function with wrong name is wrong.

Thread Previous | Thread Next Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at | Group listing | About