develooper Front page | perl.perl5.porters | Postings from February 2017

Re: Proposal: Rename utf8::is_utf8() to utf8::is_upgraded()

Thread Previous | Thread Next
Dan Book
February 19, 2017 18:52
Re: Proposal: Rename utf8::is_utf8() to utf8::is_upgraded()
Message ID:
On Sun, Feb 19, 2017 at 1:41 PM, Father Chrysostomos <>
> I do not.  The main reasons for using the function are to work around
> problems with buggy XS modules.  Adding a synonym for a function that
> most correct code should not be using seems like the wrong direction
> to be going in.

But with a synonym available, the documentation can be changed to cover the
synonym, and only mention in passing that "this function is also called
is_utf8", which would at least help with the primary issue that people are
using this function to test for UTF-8.

Thread Previous | Thread Next Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at | Group listing | About