develooper Front page | perl.perl5.porters | Postings from February 2017

Re: Proposal: Rename utf8::is_utf8() to utf8::is_upgraded()

Thread Previous | Thread Next
Father Chrysostomos
February 19, 2017 18:42
Re: Proposal: Rename utf8::is_utf8() to utf8::is_upgraded()
Message ID:
Karl Williamson wrote:
> I think it is a good idea to at least give people an opportunity to have
> a name that doesn't mislead, even if we keep the old name for back
> compatibility.  I've done that several times in the core.  The problem
> with a misleading name is that it, well, misleads.  Even if you know
> about it, in skimming code, you can be misled.

But in the end having four different ways to write AvFILL is more con-
fusing than the situation we started with.  (And av_tindex does not
seem at all an intuitive name to me.)

> So, I support adding a synonym.

I do not.  The main reasons for using the function are to work around
problems with buggy XS modules.  Adding a synonym for a function that
most correct code should not be using seems like the wrong direction
to be going in.

Thread Previous | Thread Next Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at | Group listing | About