develooper Front page | perl.perl5.porters | Postings from July 2016

[perl #128535] Allow Configure to fully customize the names ofinstalled binaries

From:
Dan Collins
Date:
July 4, 2016 19:49
Subject:
[perl #128535] Allow Configure to fully customize the names ofinstalled binaries
Message ID:
rt-4.0.18-15835-1467661760-878.128535-75-0@perl.org
# New Ticket Created by  Dan Collins 
# Please include the string:  [perl #128535]
# in the subject line of all future correspondence about this issue. 
# <URL: https://rt.perl.org/Ticket/Display.html?id=128535 >


-Dversiononly currently allows us to install 'perl5.25.0' and so on, instead of just 'perl'. It would be helpful to also allow other installations to coexist. For example, we might ask "append other configuration options to the suffix?" "would you like to customize the suffix?" The suffix might then be "5.25.0-ld-thread-multi".

In addition to installing the binary as "perl5.25.0-ld-thread-multi", this defined suffix would then also be used as the default for the $version component in library and manual directories.

I'll give implementing this a shot, unless this is a bad idea.




nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About