develooper Front page | perl.perl5.porters | Postings from May 2016

[perl #128200] documentation shouldn't recommend usenet

From:
l . mai @ web . de
Date:
May 20, 2016 21:41
Subject:
[perl #128200] documentation shouldn't recommend usenet
Message ID:
rt-4.0.18-28858-1463780467-681.128200-75-0@perl.org
# New Ticket Created by  l.mai@web.de 
# Please include the string:  [perl #128200]
# in the subject line of all future correspondence about this issue. 
# <URL: https://rt.perl.org/Ticket/Display.html?id=128200 >



This is a bug report for perl from l.mai@web.de,
generated with the help of perlbug 1.40 running under perl 5.24.0.


-----------------------------------------------------------------
[Please describe your issue here]

Several files in the perl distribution reference usenet (comp.lang.perl.misc
and friends). I don't think this is useful. I personally haven't used
newsgroups in more than a decade (so I don't know whether anyone is still
there), but I doubt the current generation (or generations?) of programmers has
even heard of usenet.

Affected files:

- pod/perlmodlib.PL

| How to release and distribute a module.
| 
| It's good idea to post an announcement of the availability of your
| Module (or the module itself if small) to the comp.lang.perl.announce
| Usenet newsgroup.  This will at least ensure very wide once-off
| Distribution.
| 
| If possible, register the module with CPAN.  You should
| Include details of its location in your announcement.

This seems very outdated.


- pod/perlnewmod.pod

| =item Discuss the need
| 
| You might love it. You might feel that everyone else needs it. But there
| might not actually be any real demand for it out there. If you're unsure
| about the demand your module will have, consider sending out feelers
| on the C<comp.lang.perl.modules> newsgroup, or as a last resort, ask the
| modules list at C<modules@perl.org>. Remember that this is a closed list
| with a very long turn-around time - be prepared to wait a good while for
| a response from them.

I'm not sure what to recommend instead here.

| =item Announce to clpa
| 
| If you have a burning desire to tell the world about your release, post
| an announcement to the moderated C<comp.lang.perl.announce> newsgroup.

This section can probably be removed.


- pod/perlmodinstall.pod

| If you have any suggested changes for this page, let me know.  Please
| don't send me mail asking for help on how to install your modules.
| There are too many modules, and too few Orwants, for me to be able to
| answer or even acknowledge all your questions.  Contact the module
| author instead, or post to comp.lang.perl.modules, or ask someone
| familiar with Perl on your operating system.


- pod/perlcommunity.pod

| There are also plenty of Perl related newsgroups located under
| C<comp.lang.perl.*>.


- INSTALL

| Wherever possible please use the perlbug tool supplied with this Perl
| to report problems, as it automatically includes summary configuration
| information about your perl, which may help us track down problems far
| more quickly. But first you should read the advice in this file,
| carefully re-read the error message and check the relevant manual pages
| on your system, as these may help you find an immediate solution.  If
| you are not sure whether what you are seeing is a bug, you can send a
| message describing the problem to the comp.lang.perl.misc newsgroup to
| get advice.


- Porting/pumpkin.pod

| You should definitely announce your patch on the perl5-porters list.
| You should also consider announcing your patch on
| comp.lang.perl.announce, though you should make it quite clear that a
| subversion is not a production release, and be prepared to deal with
| people who will not read your disclaimer.

[Please do not change anything below this line]
-----------------------------------------------------------------
---
Flags:
    category=docs
    severity=low
---
Site configuration information for perl 5.24.0:

Configured by mauke at Mon May  9 21:21:33 CEST 2016.

Summary of my perl5 (revision 5 version 24 subversion 0) configuration:
   
  Platform:
    osname=linux, osvers=4.4.5-1-arch, archname=i686-linux
    uname='linux simplicio 4.4.5-1-arch #1 smp preempt thu mar 10 07:54:30 cet 2016 i686 gnulinux '
    config_args=''
    hint=previous, useposix=true, d_sigaction=define
    useithreads=undef, usemultiplicity=undef
    use64bitint=undef, use64bitall=undef, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2 -flto',
    cppflags='-fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include'
    ccversion='', gccversion='6.1.1 20160501', gccosandvers=''
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234, doublekind=3
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12, longdblkind=3
    ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=4, prototype=define
  Linker and Libraries:
    ld='cc', ldflags ='-fstack-protector-strong -L/usr/local/lib -flto'
    libpth=/usr/local/lib /usr/lib/gcc/i686-pc-linux-gnu/6.1.1/include-fixed /usr/lib /lib /usr/local/lib /usr/lib/gcc/i686-pc-linux-gnu/6.1.1/include-fixed /usr/lib
    libs=-lpthread -lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc -lgdbm_compat
    perllibs=-lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
    libc=libc-2.23.so, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.23'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -flto -L/usr/local/lib -fstack-protector-strong'


---
@INC for perl 5.24.0:
    /home/mauke/usr/lib/perl5/site_perl/5.24.0/i686-linux
    /home/mauke/usr/lib/perl5/site_perl/5.24.0
    /home/mauke/usr/lib/perl5/5.24.0/i686-linux
    /home/mauke/usr/lib/perl5/5.24.0
    .

---
Environment for perl 5.24.0:
    HOME=/home/mauke
    LANG=en_US.UTF-8
    LANGUAGE=en_US
    LC_COLLATE=C
    LC_MONETARY=de_DE.UTF-8
    LC_TIME=de_DE.UTF-8
    LD_LIBRARY_PATH (unset)
    LOGDIR (unset)
    PATH=/home/mauke/perl5/perlbrew/bin:/home/mauke/bin:/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl
    PERLBREW_BASHRC_VERSION=0.73
    PERLBREW_HOME=/home/mauke/.perlbrew
    PERLBREW_ROOT=/home/mauke/perl5/perlbrew
    PERL_BADLANG (unset)
    PERL_UNICODE=SAL
    SHELL=/bin/bash




nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About