develooper Front page | perl.perl5.porters | Postings from April 2016

[perl #127810] Provide -Dfortify_inc Configure option to remove .from @INC

Thread Previous | Thread Next
Todd Rinaldo via RT
April 4, 2016 17:38
[perl #127810] Provide -Dfortify_inc Configure option to remove .from @INC
Message ID:
On Fri Apr 01 14:24:46 2016, sprout wrote:
> On Fri Apr 01 07:29:03 2016, davem wrote:
> > I'm not familiar enough with the config system to know whether the
> > fortify_inc probe should be called d_fortify_inc or something
> > instead,
I inquired about that a couple of weeks ago. I was informed there was no rhyme / reason / consistency to the use of d_ in Configure script variables. fortify_inc seems to be more intuitive so I went with that.

> > I also wonder whether the define in config.h should be prefixed with
> > PERL. 'FORTIFY_INC' is pretty generic and could conceivably clash
> > with
> > something else.
> PERL_FORTIFY_INC is definitely better.

Agreed. I'll update the patch on the github remote.

via perlbug:  queue: perl5 status: open

Thread Previous | Thread Next Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at | Group listing | About