develooper Front page | perl.perl5.porters | Postings from April 2016

[perl #127810] Provide -Dfortify_inc Configure option to remove .from @INC

Thread Previous
Father Chrysostomos via RT
April 1, 2016 21:24
[perl #127810] Provide -Dfortify_inc Configure option to remove .from @INC
Message ID:
On Fri Apr 01 07:29:03 2016, davem wrote:
> I'm not familiar enough with the config system to know whether the
> fortify_inc probe should be called d_fortify_inc or something instead,

Optionally, one can side-step the whole issue by using -Accflags=-DFORTIFY_INC, but that depends on how much you want this to be perceived as an option for ‘geeks’.

> I also wonder whether the define in config.h should be prefixed with
> PERL. 'FORTIFY_INC' is pretty generic and could conceivably clash with
> something else.

PERL_FORTIFY_INC is definitely better.


Father Chrysostomos

via perlbug:  queue: perl5 status: open

Thread Previous Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at | Group listing | About