develooper Front page | perl.perl5.porters | Postings from May 2015

[5.22?] perl 5.20.2 fails to compile with gcc 5.1.0 -flto -O2

Thread Previous | Thread Next
From:
H.Merijn Brand
Date:
May 8, 2015 14:51
Subject:
[5.22?] perl 5.20.2 fails to compile with gcc 5.1.0 -flto -O2
Message ID:
20150508165128.442ccf69@pc09.procura.nl
On Wed, 6 May 2015 17:49:27 -0700, "Tony Cook via RT"
<perlbug-followup@perl.org> wrote:

> Not every compiler supports gcc's extensions, so we need to probe for
> __attribute__ ((used)) before we use it.
> 
> The attached patch is against bleadperl, detected __attribute__((used)), and if
> found uses it in the csym code.
> 
> If you want to test this againt 5.20 you should be able to copy Configure from blead and apply that patch to it, or copy Configure from:
> 
>  http://perl5.git.perl.org/perl.git/blob_plain/refs/heads/tonyc/attribute-used:/Configure
> 
> I couldn't reproduce the problem you were having however - with your options with gcc 5.1.0 malloc_size wasn't being detected (Debian oldstable.)
> 
> Tony

Committers: if you think this should be in 5.22, I will need AT LEAST 2
+1's and the blessing of the pumpkin.

Otherwise, I will revisit this for 5.23

Note that the remark "this is a trivial patch" is way besides the
truth, as we all know :)

-- 
H.Merijn Brand  http://tux.nl   Perl Monger  http://amsterdam.pm.org/
using perl5.00307 .. 5.21   porting perl5 on HP-UX, AIX, and openSUSE
http://mirrors.develooper.com/hpux/        http://www.test-smoke.org/
http://qa.perl.org   http://www.goldmark.org/jeff/stupid-disclaimers/

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About