develooper Front page | perl.perl5.porters | Postings from May 2015

Re: [perl #123213] New sub(){$var} deprecation breaks CPAN

Thread Previous
From:
Dave Mitchell
Date:
May 6, 2015 14:36
Subject:
Re: [perl #123213] New sub(){$var} deprecation breaks CPAN
Message ID:
20150506143556.GA6987@iabyn.com
On Tue, Apr 07, 2015 at 05:19:51PM -0700, Tony Cook via RT wrote:
> Out of the dists mentioned so far, the following haven't had fixes released:
> 
> HKOBA/YATT-Lite-0.0.9.tar.gz
> HKOBA/YATT-v0.0.8.tar.gz - https://rt.cpan.org/Ticket/Display.html?id=95311 - author said he'd fix both dists in this ticket

There have since been releases of both these modules that claim to be
fixed.

> ABW/Badger-0.09.tar.gz -
> https://rt.cpan.org/Ticket/Display.html?id=99200 - fixed in git at
> https://github.com/abw/Badger

Still no new release

> SAMV/Net-SSLeay-OO-0.02.tar.gz - https://rt.cpan.org/Ticket/Display.html?id=100364 - no response to ticket since November

No new release since 2009.

> JSWARTZ/Mason-2.22.tar.gz -
> https://rt.cpan.org/Ticket/Display.html?id=100507 - has a patch, has had
> a few recent releases without this being fixed

Still unfixed. I've just emailed the author asking if he's aware of the
ticket.

My feeling is that this ticket no longer needs to be blocker.

-- 
Dave's first rule of Opera:
If something needs saying, say it: don't warble it.

Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About