develooper Front page | perl.perl5.porters | Postings from September 2014

Re: CPAN smokes and [perl #121638] 'Global symbol "$identifier"requires explicit package' error message

Thread Previous | Thread Next
From:
Karen Etheridge
Date:
September 20, 2014 05:38
Subject:
Re: CPAN smokes and [perl #121638] 'Global symbol "$identifier"requires explicit package' error message
Message ID:
20140920053835.GB34472@tequila
On Fri, Sep 19, 2014 at 10:57:54PM -0000, Father Chrysostomos wrote:
> Karl Williamson wrote:
> > On 09/18/2014 11:13 PM, Father Chrysostomos via RT wrote:
> > > Added in d8c6310a4f.  This ticket is resolved.  Let's see how much of CPAN this breaks. :-)
> > >
> > 
> > While you were off-list earlier this year, we decided to avoid using
> > blead as a CPAN smoker for things we suspect are likely to break it.
> 
> I meant that last sentence solely as a joke.  Even if this does break
> CPAN, I think this change should still stay in.
> 
> Even if I had done a smoke first and found that Function::Parameters,
> Mouse, Apache::EmbeddedPerl::Lite, triceps, Moose,
> Parse::Keyword, Dancer, lib-with-preamble, DBIx::VersionedSubs,
> MooseX::Method::Signatures Acme::use::strict::with::pride, Coat,
> Config::Vars and Padre are likely to break, I would have applied
> it anyway.

Moose has been fixed in versions 2.1212 and 2.1303-TRIAL. You have my
permission to release 5.21.4 now.*


* this seems like a fun game. :)

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About