develooper Front page | perl.perl5.porters | Postings from August 2014

[perl #121638] 'Global symbol "$identifier" requires explicit package' error message

Thread Previous | Thread Next
From:
Karl Williamson via RT
Date:
August 22, 2014 20:10
Subject:
[perl #121638] 'Global symbol "$identifier" requires explicit package' error message
Message ID:
rt-4.0.18-6710-1408738218-1639.121638-15-0@perl.org
I tried a CPAN smoke of changing this message.  The high level results are attached as the first file.

If I look at the failures, the ones which have the changed wording in their test output amount to 130 distinct distributions.  The second attachment is an example of an expected failure there.

But some of the failures are more like the third attachment.  And looking at the smoke output, a lot of things failed because of failed prerequisites.  Steffen doesn't understand it.  The code is using cpanplus to compile things.

And there is that the output says 2800 distributions are missing from the output; also something I and Steffen don't understand.

So I'm not sure how to proceed.  What do you think?


-- 
Karl Williamson

---
via perlbug:  queue: perl5 status: open
https://rt.perl.org/Ticket/Display.html?id=121638

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About