develooper Front page | perl.perl5.porters | Postings from December 2013

[perl #119859] Bleadperl v5.19.3-555-g24d2b81 breaks AUBERTG/Test-Dist-VersionSync-1.1.2.tar.gz

Thread Previous | Thread Next
From:
Father Chrysostomos via RT
Date:
December 23, 2013 00:19
Subject:
[perl #119859] Bleadperl v5.19.3-555-g24d2b81 breaks AUBERTG/Test-Dist-VersionSync-1.1.2.tar.gz
Message ID:
rt-4.0.18-27705-1387757931-1889.119859-15-0@perl.org
On Mon Sep 16 20:41:37 2013, sprout wrote:
> On Mon Sep 16 19:19:15 2013, andreas.koenig.7os6VVqR@franz.ak.mind.de wrote:
> > git bisect
> > ----------
> > commit 24d2b81b3ff70401bb05666e9fd5c39bb0f6120a
> > Author: Father Chrysostomos <sprout@cpan.org>
> > Date:   Sun Sep 15 13:10:33 2013 -0700
> > 
> >     Use dev version for Test::Builder et al.
> > 
> > diagnostics
> > -----------
> > Cpantesters hasn't yet processed my results. But there were reports
> > about 0.98_0[45]:
> > https://github.com/guillaumeaubert/Test-Dist-VersionSync/issues/1
> > https://github.com/guillaumeaubert/Test-Dist-VersionSync/issues/2
> > 
> > From that I suppose, the module has special cases for individual
> > Test::Builder versions and is now irritated by 0.98_06 because it does
> > not have some behaviour that was in 0.98_05.
> 
> Ugh.  What to do about *that*?  I suppose if we make sure that
> Test::Builder/Simple/More gets a new non-dev release before 5.20, the
> problem will go away.  I’ll link this to the meta ticket, so we can make
> sure *this* aspect of the problem is resolved in time.
> 

Resolved:

$ corelist5.19.7 -a Test::Builder -v 5.19.7
Test::Builder 1.001002


-- 

Father Chrysostomos


---
via perlbug:  queue: perl5 status: open
https://rt.perl.org/Ticket/Display.html?id=119859

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About