develooper Front page | perl.perl5.porters | Postings from October 2013

[perl #119879] Cannot install module requiring perl-5.6 via 'cpan'

From:
Steve Hay via RT
Date:
October 3, 2013 16:53
Subject:
[perl #119879] Cannot install module requiring perl-5.6 via 'cpan'
Message ID:
rt-3.6.HEAD-31239-1380819223-496.119879-15-0@perl.org
On Wed Sep 18 05:37:54 2013, nicholas wrote:
> On Wed, Sep 18, 2013 at 01:22:29PM +0100, Steve Hay wrote:
> > On 18 September 2013 12:54, Leon Timmermans <fawaka@gmail.com> wrote:
> > > On Wed, Sep 18, 2013 at 1:12 PM, Steve Hay <perlbug-followup@perl.org>
> 
> > >> The same thing worked fine in perl-5.19.3.
> > >
> > >
> > > It shouldn't have. If it did, I would guess that's because it was
being
> > > ignored somehow.
> > 
> > It certainly did "work", and likewise in earlier (stable) perls too --
> > at least 5.18.0 and 5.18.1; I haven't tried further back.
> > 
> > Let's hope there aren't too many CPAN distros out there harbouring the
> > same problem, which has evidently been masked for some time!
> 
> Possibly stupid question - do we know what change actually fixed this?
> (The old behaviour does seem to be a bug)
> 

It was actually the upgrade of CPAN from 2.00 to 2.03-TRIAL which fixed
the previously broken behaviour, in particular the various changes to
the 'make' logic affecting satisfy_requires() in CPAN::Distribution; the
CPAN::Version logic to compare version numbers (vgt() in this case) is
unchanged.

---
via perlbug:  queue: perl5 status: open
https://rt.perl.org:443/rt3/Ticket/Display.html?id=119879



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About