develooper Front page | perl.perl5.porters | Postings from September 2013

Re: [perl #119879] Cannot install module requiring perl-5.6 via 'cpan'

Thread Previous | Thread Next
From:
Steve Hay
Date:
September 18, 2013 12:22
Subject:
Re: [perl #119879] Cannot install module requiring perl-5.6 via 'cpan'
Message ID:
CADED=K5t2c_Vfi31bCSmOvHMDCNEghtvUXKR46KQrQFinYoXOw@mail.gmail.com
On 18 September 2013 12:54, Leon Timmermans <fawaka@gmail.com> wrote:
> On Wed, Sep 18, 2013 at 1:12 PM, Steve Hay <perlbug-followup@perl.org>
> wrote:
>>
>> With a fresh installation of blead (patchlevel as below) and a fresh
>> .cpan folder in C:\Users\shay I can no longer use 'cpan' to install a
>> simple CPAN distribution in which the META.yml file says
>>
>> requires:
>>   perl: 5.6
>>
>> For example, with Win32::WinError I get this output:
>>
>> cpan[1]> install Win32::WinError
>> [...]
>> Configuring J/JD/JDB/Win32-WinError-0.03.tar.gz with Makefile.PL
>> Checking if your kit is complete...
>> Looks good
>> Generating a nmake-style Makefile
>> Writing Makefile for Win32::WinError
>> Writing MYMETA.yml and MYMETA.json
>>   JDB/Win32-WinError-0.03.tar.gz
>>   C:\perl\bin\perl.exe Makefile.PL -- OK
>> Running make for J/JD/JDB/Win32-WinError-0.03.tar.gz
>> JDB/Win32-WinError-0.03.tar.gz requires perl '5.6'; you have only
>> 5.019004; giving up
>>   JDB/Win32-WinError-0.03.tar.gz
>>   [prereq] -- NOT OK
>
>
> It's supposed to be written as 5.006, not 5.6. The latter is equal to
> 5.600.0, which we won't be at for a fairly long time.
>

Ah, yes. I have "perl: 5.6.0" in some of my distros' META.yml files. I
forgot that 5.6 is different to 5.6.0...

So that's a problem with the Win32-WinError distro then. Searching
through other distros that I use I find the same thing in numerous
others too, nearly all originating from the old libwin32 bundle:

Win32-Console-0.09\META.yml:  perl: 5.6
Win32-Daemon-20110117\META.yml:  perl: 5.6
Win32-EventLog-0.076\META.yml:  perl: 5.6
Win32-File-0.06\META.yml:  perl: 5.6
Win32-OLE-0.1709\META.yml:  perl: 5.6
Win32-Process-0.14\META.yml:  perl: 5.6
Win32-Registry-0.10\META.yml:  perl: 5.6
Win32-Shortcut-0.07\META.yml:  perl: 5.6
Win32-Sound-0.51\META.yml:  perl: 5.6
Win32-WinError-0.03\META.yml:  perl: 5.6

Jan: Please could you roll out new releases of these (and any other
affacted) distros before 5.20.0 hits the streets? I can raise a bunch
of CPAN/RT tickets to remind you if you like, but it otherwise seems
unecessary effort for such a minor thing.


>>
>> The same thing worked fine in perl-5.19.3.
>
>
> It shouldn't have. If it did, I would guess that's because it was being
> ignored somehow.

It certainly did "work", and likewise in earlier (stable) perls too --
at least 5.18.0 and 5.18.1; I haven't tried further back.

Let's hope there aren't too many CPAN distros out there harbouring the
same problem, which has evidently been masked for some time!

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About