develooper Front page | perl.perl5.porters | Postings from September 2013

Re: [perl #119879] Cannot install module requiring perl-5.6 via 'cpan'

Thread Previous | Thread Next
From:
Leon Timmermans
Date:
September 18, 2013 11:55
Subject:
Re: [perl #119879] Cannot install module requiring perl-5.6 via 'cpan'
Message ID:
CAHhgV8gQmPM2-c76wcL_p3PHHREW8p2x2=NuuuJHUAcfq=KBDQ@mail.gmail.com
On Wed, Sep 18, 2013 at 1:12 PM, Steve Hay <perlbug-followup@perl.org>wrote:

> With a fresh installation of blead (patchlevel as below) and a fresh
> .cpan folder in C:\Users\shay I can no longer use 'cpan' to install a
> simple CPAN distribution in which the META.yml file says
>
> requires:
>   perl: 5.6
>
> For example, with Win32::WinError I get this output:
>
> cpan[1]> install Win32::WinError
> [...]
> Configuring J/JD/JDB/Win32-WinError-0.03.tar.gz with Makefile.PL
> Checking if your kit is complete...
> Looks good
> Generating a nmake-style Makefile
> Writing Makefile for Win32::WinError
> Writing MYMETA.yml and MYMETA.json
>   JDB/Win32-WinError-0.03.tar.gz
>   C:\perl\bin\perl.exe Makefile.PL -- OK
> Running make for J/JD/JDB/Win32-WinError-0.03.tar.gz
> JDB/Win32-WinError-0.03.tar.gz requires perl '5.6'; you have only
> 5.019004; giving up
>   JDB/Win32-WinError-0.03.tar.gz
>   [prereq] -- NOT OK
>

It's supposed to be written as 5.006, not 5.6. The latter is equal to
5.600.0, which we won't be at for a fairly long time.


> The same thing worked fine in perl-5.19.3.
>

It shouldn't have. If it did, I would guess that's because it was being
ignored somehow.

Leon

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About