develooper Front page | perl.perl5.porters | Postings from March 2013

[perl #117283] Useless dependency in Exporter meta-data

From:
James E Keenan via RT
Date:
March 31, 2013 01:32
Subject:
[perl #117283] Useless dependency in Exporter meta-data
Message ID:
rt-3.6.HEAD-28177-1364693543-173.117283-15-0@perl.org
On Fri Mar 22 02:39:53 2013, ppisar wrote:
> 
> This is a bug report for perl from ppisar@redhat.com,
> generated with the help of perlbug 1.39 running under perl 5.16.2.
> 
> 
> -----------------------------------------------------------------
> 
> Exporter-5.67 Makefile.PL recommends Test::Pod::Coverage 1.04 which is
>    not
> used anywhere in the Exporter's test suite:
> 
> petr@dhcp-0-146:/tmp/Exporter-5.67 $ grep -Hnr Test::Pod::Coverage
> META.yml:22:  Test::Pod::Coverage: 1.04
> META.json:36:            "Test::Pod::Coverage" : "1.04"
> Makefile.PL:20:            'Test::Pod::Coverage' => 1.04
> 
> I recommend to remove it.
> 
> -- Petr
> 

This is a curious case.  Porting/Maintainers.pl describes Exporter as
being maintained in blead.  But the problem you report -- which is
accurate -- is limited to the Exporter distribution on CPAN.  There is
no Makefile for Exporter in blead.

I'm cc-ing maintainers of Exporter in the hope they can respond.

Thank you very much.
Jim Keenan

---
via perlbug:  queue: perl5 status: new
https://rt.perl.org:443/rt3/Ticket/Display.html?id=117283



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About