develooper Front page | perl.perl5.porters | Postings from February 2013

[perl #59456] Perl 5.8.8 Build Failures for SunOS 4.1.3

Thread Previous
From:
Claudio via RT
Date:
February 28, 2013 19:44
Subject:
[perl #59456] Perl 5.8.8 Build Failures for SunOS 4.1.3
Message ID:
rt-3.6.HEAD-31961-1362079580-1229.59456-15-0@perl.org
On Sun Feb 24 15:17:25 2013, jkeenan wrote:
> On Sun Oct 05 11:16:52 2008, doughera wrote:
> > On Sat, 4 Oct 2008, Nicholas Clark wrote:
> > 
> > > On Mon, Sep 29, 2008 at 01:48:23PM -0700, Peterson, Bob D (MN14)
> > wrote:
> > >
> > > > We need a relatively new version of perl running on "SunOS cxh
> > 4.1.3_U1
> > > > 3 sun4m". We can't upgrade the OS because of frozen vendor
> > software. I
> > >
> > > Gosh. That's rather frozen.
> > > Whilst Perl 5.000 was first developed on SunOS, I don't know if
> > anyone
> > > has tried to build it there recently.
> > 
> > I don't think I've tried in many years.  Probably not since 2001.
> > 
> > > > I'm not experienced with large scale builds like this, but I
> > thought I
> > > > would try it anyways. The compiler used was "gcc".
> > > >
> > > > The build itself went okay (quite a few "implicit function
> > declaration"
> > > > warnings) but some of the tests are failing. To the inexperienced
> > eye,
> > > > it looks like the most troublesome problem is the "lib/sort" test.
> > I
> > > > expect that we'll be using sort extensively.
> > >
> > > Yes. That looks like a potential problem.
> > 
> > I vaguely recall runing into some gcc-specific sparc optimization
> > issues
> > some years ago in the sort routines.  I'd be strongly inclined to try
> > again without any optimization.
> > 
> > > What is the value of $^O on SunOS 4? (And for that matter on SunOS 5
> > - I don't
> > > have access to anything Solaris any more)
> > 
> > I think both are 'sunos'.
> > 
> 
> I reviewed this ticket today.  The original poster has not responded in
> more than four years.  The version of Perl in question is out of
> support.  I recommend the ticket be closed.  I will do so in seven days
> unless someone wishes to take over the discussion and move it in a
> constructive direction.
> 
> Thank you very much.
> Jim Keenan

I propose to close this ticket because not only is the Perl version out
of support, but the Operating System is ancient: SunOS 4 was out of
support on September 2003, SunOS 5 in December 2003
(http://en.wikipedia.org/wiki/Solaris_%28operating_system%29#Version_history).
From anecdotal evidence (as imho), most of the Solaris installer base
are running Solaris 10, while you may find some
ancient-and-not-supported Solaris 8 installations. Everything older than
that is extremely rare. Furthermore, Perl 5.16.2 builds on Solaris 10
with gcc.

Regards,

Claudio




---
via perlbug:  queue: perl5 status: open
https://rt.perl.org:443/rt3/Ticket/Display.html?id=59456

Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About