develooper Front page | perl.perl5.porters | Postings from February 2013

Re: [perl #116915] require a "I know EBCDIC is threatened" switch toConfigure

Thread Previous | Thread Next
From:
Nicholas Clark
Date:
February 25, 2013 22:45
Subject:
Re: [perl #116915] require a "I know EBCDIC is threatened" switch toConfigure
Message ID:
20130225224505.GL5653@plum.flirble.org
On Mon, Feb 25, 2013 at 04:04:04PM -0600, Craig A. Berry wrote:

> But running a Perl module depends on having a port of Perl, which is
> the one thing he doesn't have (I don't *think* he does; it's possible
> a much older Perl for z/OS could be rustled up somewhere).

IBM's own website says that 5.8.7 is available. I've just built 5.8.7
from source on Linux and used its CPAN shell to install Test::Smoke.
It all works.

(after I realised that I needed to upgrade ExtUtils::MakeMaker
before trying to build Test::Smoke, as IO::HTML has a dependency on an
upgraded ExtUtils::MakeMaker, and the CPAN client in 5.8.7 is too old to
do "configure_requires".)

So using 5.8.7 to drive Test::Smoke to smoke blead should work just fine.

Nicholas Clark

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About