develooper Front page | perl.perl5.porters | Postings from February 2013

[perl #59922] Errors in compilation

Thread Next
From:
James E Keenan via RT
Date:
February 24, 2013 23:14
Subject:
[perl #59922] Errors in compilation
Message ID:
rt-3.6.HEAD-31961-1361747634-1078.59922-15-0@perl.org
On Thu Nov 13 06:38:50 2008, RajiniS wrote:
> 
> 
> 
> >-----Original Message-----
> >From: Andy Dougherty via RT [mailto:perlbug-followup@perl.org]
> >Sent: Saturday, October 25, 2008 1:54 AM
> >To: S, Rajini (STSD)
> >Subject: RE: [perl #59922] Errors in compilation
> >
> >On Wed, 22 Oct 2008, S, Rajini (STSD) wrote:
> >
> >> We were able to triage the failure for the below  error. We
> >had to set
> >> PERL5LIB path and testcases  with unsatisfied code symbol are now
> >> passing.
> >>  Now the errors have come down from 48 to 31.
> >>
> >> We are now facing memory fault errors for few testcases.
> >>
> >> Testcase name :
> >/aperlz/cpan/perl-5.8.8/ext/Storable/t/attach_errors.t
> >>
> >> We are trying to compile the testcase with perl.
> >>
> >> $/aperlz/cpan/perl-5.8.8/perl attach_errors.t
> >> 1..35
> >> Memory fault
> >>
> >> We are getting memory fault error, could you please us solve this
> is
> >> issue.
> >
> >I still suspect that your new perl is loading files from a
> >previous installation.  When you run
> >
> >    $/aperlz/cpan/perl-5.8.8/perl attach_errors.t
> >
> >the perl binary goes and looks for its libraries in the
> >directories specified by @INC.  Unless you have changed things
> >from your previous report, @INC pointed to an old, different
> >installation of perl.  Thus your newly-built perl is trying to
> >load files from the old, different installation of perl.
> >
> >I know that it's picking up files from somewhere outside the
> >build directory because unless you have installed *this*
> >version of perl already, you should have received the message:
> >
> >    Can't locate Config.pm in @INC (@INC contains: [ list of
> >    directories in @INC] [ . . . ]
> >    BEGIN failed--compilation aborted at attach_errors.t line 27.
> >
> 
> 
> 
>    We have set LD_LIBRARY_PATH and PERL5LIB to /aperlz/cpan/perl-
> 5.8.8.
>    So the perl is loading libraries from the /aperlz/cpan/perl-5.8.8
> location
>    and we never hit the error "Can't locate Config.pm...... In @INC"
> 
> 
> 
> 
> 
> 
> -Rajini
> 
> 
> 
> 
> 
> 
> 
> 
> >--
> >    Andy Dougherty              doughera@lafayette.edu
> >
> >
> >
> 


Since (a) the original poster has not posted further in more than four
years, (b) what the original poster was trying to do seemed questionable
and (c) the version of Perl he was trying to install is out of support,
I recommend this ticket be closed.

I will do so in seven days unless someone wishes to take over the issue.

Thank you very much.
Jim Keenan

---
via perlbug:  queue: perl5 status: open
https://rt.perl.org:443/rt3/Ticket/Display.html?id=59922

Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About