develooper Front page | perl.perl5.porters | Postings from February 2013

Re: [perl #116821] B::Deparse warnings during build of 5.17.9

Thread Previous | Thread Next
From:
Aaron Crane
Date:
February 18, 2013 13:18
Subject:
Re: [perl #116821] B::Deparse warnings during build of 5.17.9
Message ID:
CACmk_tvW8vJGZ1MP1HCDxFgezwuJuh84VXNa=k4mdoZGsicxxA@mail.gmail.com
yves orton <perlbug-followup@perl.org> wrote:
> I see these warnings. I do not think they are related to my local changes.
>
> Yves
>
> dist/B-Deparse/t/deparse ...................................... The
> lexical_subs feature is experimental at (eval 304) line 14, <DATA>
> chunk 139.
> unexpected OP_INTROCV at ../../lib/B/Deparse.pm line 1250, <DATA> chunk 139.
> unexpected OP_CLONECV at ../../lib/B/Deparse.pm line 1250, <DATA> chunk 139.
> unexpected OP_PADCV at ../../lib/B/Deparse.pm line 1250, <DATA> chunk 139.
> ok

These warnings come from dist/B-Deparse/t/deparse.t; specifically,
this TODO test (currently at the bottom):

# SKIP ?$] < 5.017004 && "lexical subs not implemented on this Perl version"
# TODO unimplemented in B::Deparse; RT #116553
# lexical subroutine
use feature 'lexical_subs';
my sub f {}
print f();

I think this ticket can be merged into #116553; any disagreement?

-- 
Aaron Crane ** http://aaroncrane.co.uk/

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About