develooper Front page | perl.perl5.porters | Postings from February 2013

[perl #114924] Bleadperl v5.17.3-379-g3c104e5 breaks CHROMATIC/SUPER-1.20120705.tar.gz

Thread Previous | Thread Next
From:
Ricardo SIGNES via RT
Date:
February 8, 2013 16:34
Subject:
[perl #114924] Bleadperl v5.17.3-379-g3c104e5 breaks CHROMATIC/SUPER-1.20120705.tar.gz
Message ID:
rt-3.6.HEAD-27190-1360341263-910.114924-15-0@perl.org
On Wed Sep 19 08:40:09 2012, sprout wrote:
> UR is relying on undocumented behaviour that causes bugs elsewhere.
> 
> It expects to be able to call "Foo::SUPER"->can(...).
> 
> Patching the module to work around this would only be a few lines.  I
> think the module itself should change.
> 
> Any opinions?

Agreed.

File https://rt.cpan.org/Ticket/Display.html?id=83218

Closing this ticket.

-- 
rjbs

---
via perlbug:  queue: perl5 status: open
https://rt.perl.org:443/rt3/Ticket/Display.html?id=114924

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About