develooper Front page | perl.perl5.porters | Postings from September 2012

[perl #115048] [PATCH 2/2] Suggest cause of error requiring .pm file.

From:
Father Chrysostomos via RT
Date:
September 30, 2012 00:11
Subject:
[perl #115048] [PATCH 2/2] Suggest cause of error requiring .pm file.
Message ID:
rt-3.6.HEAD-11172-1348989055-724.115048-15-0@perl.org
On Wed Sep 26 18:30:27 2012, tonyc wrote:
> On Wed, Sep 26, 2012 at 04:30:59PM +0200, Aristotle Pagaltzis wrote:
> > * Paul Johnson <paul@pjcj.net> [2012-09-26 11:30]:
> > > $ perl -e 'foo->bar'
> > > Can't locate object method "bar" via package "foo" (perhaps you forgot
> > > to load "foo"?) at -e line 1.
> > >
> > > someone earlier suggested this or something similar:
> > >
> > > (perhaps you have not installed the xxxxx module?)
> > 
> > That avoids the issue Smylers noted too. It’s not quite as parallel to
> > the other message as the original suggestion but I like it better this
> > way. It is the “perhaps” that is the crucial part to my mind.
> 
> Perhaps:
> 
> (you may need to install the xxxxx module)
> 
> (yay, bikeshedding)

I think that is the best suggestion so far.  I have applied the patch,
with that wording, as f7ee53b552.  Thank you to both of you.

-- 

Father Chrysostomos


---
via perlbug:  queue: perl5 status: open
https://rt.perl.org:443/rt3/Ticket/Display.html?id=115048



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About