develooper Front page | perl.perl5.porters | Postings from October 2011

perl 5.14.2 make test fails under Solaris 10 x64

Thread Next
From:
Stefan Parvu
Date:
October 30, 2011 10:56
Subject:
perl 5.14.2 make test fails under Solaris 10 x64
Message ID:
20111030175638.GD12463@sdrdev.systemdatarecorder.org
Hello,

Im trying to build Perl 5.14.2 under Solaris 10 x64. Previously 
versions, 5.12.x worked fine. Now it seems that the perl distro
does not build, failing on many tests:

t/porting/authors..............................................skipped
t/porting/bincompat............................................ok
t/porting/buildtoc.............................................ok
t/porting/checkcase............................................ok
t/porting/cmp_version..........................................skipped
t/porting/diag.................................................ok
t/porting/dual-life............................................ok
t/porting/exec-bit.............................................ok
t/porting/filenames............................................ok
t/porting/maintainers..........................................ok
t/porting/manifest.............................................ok
t/porting/podcheck.............................................ok
t/porting/regen................................................ok
t/porting/test_bootstrap.......................................ok
Failed 10 tests out of 1961, 99.49% okay.
        ../cpan/autodie/t/context.t
        ../cpan/autodie/t/context_lexical.t
        ../cpan/autodie/t/format-clobber.t
        ../cpan/autodie/t/usersub.t
        ../dist/Storable/t/attach_errors.t
        op/blocks.t
        op/caller.t
        op/gv.t
        op/method.t
        op/stash.t
### Since not all tests were successful, you may want to run some of
### them individually and examine any diagnostic messages they produce.
### See the INSTALL document's section on "make test".
### You have a good chance to get more information by running
###   ./perl harness
### in the 't' directory since most (>=80%) of the tests succeeded.
### You may have to set your dynamic library search path,
### LD_LIBRARY_PATH, to point to the build directory:
###   setenv LD_LIBRARY_PATH `pwd`; cd t; ./perl harness
###   LD_LIBRARY_PATH=`pwd`; export LD_LIBRARY_PATH; cd t; ./perl harness
###   export LD_LIBRARY_PATH=`pwd`; cd t; ./perl harness
### for csh-style shells, like tcsh; or for traditional/modern
### Bourne-style shells, like bash, ksh, and zsh, respectively.
u=8.54  s=5.61  cu=390.16  cs=76.77  scripts=1961  tests=455025
*** Error code 1
make: Fatal error: Command failed for target `test'


The command to build perl was:

sh Configure -Dcc='cc' -Doptimize='-xO3' -Duselargefiles -Duse64bitall \
             -Dprefix=${iprefix}/perl -des

As well it seems related with -Duse64bitall option passed to Configure. If Im not
using 64bitall everything seems to be ok for these configs.

Any ideas, hints ?

Many thanks,
Stefan


Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About