develooper Front page | perl.perl5.porters | Postings from October 2011

feature.pm proposal

Thread Next
From:
Father Chrysostomos
Date:
October 23, 2011 16:15
Subject:
feature.pm proposal
Message ID:
EF6610F2-F828-4A63-AB7D-31CCE9C66C1A@cpan.org
Under Jesse’s new plan for 5.16+, it would make sense for ‘use v5.14’ to turn off any 5.16 features.

   {
       use v5.16;
       # ... brand spanking new features enabled here ...
       {
           use v5.14;
           # ... only ‘fairly’ new features here ...
       }
   }
   # ... Classic ...

But should this be implemented in feature.pm (so ‘use feature ':5.14'’ disables 5.16 features) or pp_require?

To me it makes sense to have feature bundles as simple lists of features and make ‘use v5.14’ do an implicit ‘no feature ":5.16"; use feature ":5.14"’.


Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About