develooper Front page | perl.perl5.porters | Postings from October 2011

Re: Perl 5.16 and Beyond.

Thread Previous | Thread Next
From:
H.Merijn Brand
Date:
October 6, 2011 07:20
Subject:
Re: Perl 5.16 and Beyond.
Message ID:
20111006162003.10a86ccb@pc09.procura.nl
On Tue, 13 Sep 2011 17:07:23 -0400, Jesse Vincent <jesse@fsck.com>
wrote:

> On Sep 13, 2011, at 4:48 PM, Ævar Arnfjörð Bjarmason wrote:
> 
> > I agree with all the backward compatibility *goals*, but I think
> > redefining "v5.x" to mean "exactly v5.x" instead of "equal or greater
> > than v5.x" is a bit contrary to that aim.
>
> The point of the new semantics for "use v5.x" is to insulate code from
> changes to Perl's defaults. Keeping the existing semantics ensures
> that programs will break as we make changes to Perl's defaults.
> 
> We should certainly have some way for developers who want their code
> to get "the running Perl's semantics, whether it's 5.16 or 5.36" to
> hurt themselves if they want to, but it really should not be the
> default.

Will there be any difference between

require 5.010;

and

use 5.010;

?

If the require means "5.10.0 or newer" and the use means what has been
discussed everywhere, I can live with any decision made :)

-- 
H.Merijn Brand  http://tux.nl      Perl Monger  http://amsterdam.pm.org/
using 5.00307 through 5.14 and porting perl5.15.x on HP-UX 10.20, 11.00,
11.11, 11.23 and 11.31, OpenSuSE 10.1, 11.0 .. 11.4 and AIX 5.2 and 5.3.
http://mirrors.develooper.com/hpux/           http://www.test-smoke.org/
http://qa.perl.org      http://www.goldmark.org/jeff/stupid-disclaimers/

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About