develooper Front page | perl.perl5.porters | Postings from March 2011

Re: On HP-UX 11.31 IA64, Storable builds but making Storable testsfails

Thread Previous
From:
H.Merijn Brand
Date:
March 29, 2011 04:00
Subject:
Re: On HP-UX 11.31 IA64, Storable builds but making Storable testsfails
Message ID:
20110329125957.0262b444@pc09.procura.nl
On Tue, 29 Mar 2011 12:44:14 +0200, "H.Merijn Brand"
<h.m.brand@xs4all.nl> wrote:

> On Tue, 29 Mar 2011 12:08:03 +0200, "H.Merijn Brand"
> <h.m.brand@xs4all.nl> wrote:
> 
> > On Mon, 28 Mar 2011 17:24:06 +0300, Niskanen Mikko
> > <mikko.niskanen@cboss.fi> wrote:
> > 
> > > - HP-UX 11.31 on IA64 architecture, September 2010 Full OE update
> > >   (i.e. latest available, March 2011 not available yet)
> 
> March 2011 was released yesterday, and is available through SUM
> 
> > $ swlist -l product | grep -i perl
> >   Perl5-32  D.5.8.8.F  32-bit Perl Programming Language with Extensions
> >   Perl5-64  D.5.8.8.F  64-bit Perl Programming Language with Extensions
> > which is what is on the March 2010 for 11.31 application software DVD
> > 
> > That could be renewed to E.5.8.8.H according to
> > https://h20392.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=PERL
> 
> The OS DVD's from August/September 2010 contain (I just upped):
> 
> $ swlist -l product | grep -i perl
>   Perl5-32              E.5.8.8.F      32-bit Perl Programming Language with Extensions
>   Perl5-64              E.5.8.8.F      64-bit Perl Programming Language with Extensions
> 
> Now retrying with exactly the same perl ... (see bottom for 64bit perl)
> I see again why I don't use the shipped version ...

Now upped to

$ swlist -l product | grep -i perl
  Perl5-32              E.5.8.8.G      32-bit Perl Programming Language with Extensions
  Perl5-64              E.5.8.8.G      64-bit Perl Programming Language with Extensions

Which is a bit strange, as I expected %.5.8.8.H from the depot name:
perl_E.5.8.8.H_HP-UX_B.11.31_IA_PA.depot

Nothing changed

> > but I never use that perl
> > 
> > > - Current installed Storable-2.15
> > 
> > On my system, current = 2.16 for that perl
> > 
> > $ perl5.8.8 -MStorable -wle'print $Storable::VERSION'
> > 2.16
> > 
> > And what is you compiler version?
> > 
> > $ cc --version
> > cc: HP C/aC++ B3910B A.06.25.02 [Nov 25 2010]

-- 
H.Merijn Brand  http://tux.nl      Perl Monger  http://amsterdam.pm.org/
using 5.00307 through 5.12 and porting perl5.13.x on HP-UX 10.20, 11.00,
11.11, 11.23 and 11.31, OpenSuSE 10.1, 11.0 .. 11.3 and AIX 5.2 and 5.3.
http://mirrors.develooper.com/hpux/           http://www.test-smoke.org/
http://qa.perl.org      http://www.goldmark.org/jeff/stupid-disclaimers/

Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About