develooper Front page | perl.perl5.porters | Postings from March 2011

Re: MakeMaker 6.57_08 (RC1)

Thread Previous | Thread Next
From:
Michael G Schwern
Date:
March 27, 2011 16:38
Subject:
Re: MakeMaker 6.57_08 (RC1)
Message ID:
4D8FCA82.1010708@pobox.com
On 2011.3.28 1:17 AM, Jesse Vincent wrote:
> On Sun, Mar 27, 2011 at 10:02:42PM +1100, Michael G Schwern wrote:
>> https://github.com/Perl-Toolchain-Gang/ExtUtils-MakeMaker/tree/v6.57_08
>>
>> This is release candidate 1 for ExtUtils::MakeMaker 6.58 and hopefully will
>> make it into 5.14.0.
> 
> It won't.  If there are specific fixes we need to cherrypick, I'd like
> to us to discuss them on p5p.

Ok.


>> This release fixes an issue where MakeMaker would overwrite an installed XS
>> version of Scalar::Util with a reduced functionality pure Perl version.  It
>> will now only install Scalar::Util if it is missing entirely.  This fixes
>> issues with Compress::Zlib and breaking smokers.
> 
> That only happens on install of MM, right, so it wouldn't be an issue
> for the core.

Yes.  And the core will have a newer version of Scalar::Util so it wouldn't
trigger it anyway.


-- 
Whip me, beat me, make my code compatible with VMS!

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About