develooper Front page | perl.perl5.porters | Postings from March 2011

Re: 5.14.0 and MakeMaker (Re: Call for 5.14 release blockers)

Thread Previous | Thread Next
From:
Christian Walde
Date:
March 25, 2011 12:56
Subject:
Re: 5.14.0 and MakeMaker (Re: Call for 5.14 release blockers)
Message ID:
op.vsw0camb1fclwf@xenpad
On Fri, 25 Mar 2011 18:42:57 +0100, Jan Dubois <jand@activestate.com> wrote:

> I assume the difference in
> failures is that I built using VC (and namke), not GCC (and dmake).

Yes, the xs failures were due to EUMM configuring for make, while AP deployed MinGW.

> I believe this is a different issue that only happens when:

Yep, that sounds about right. I have to mention though that i've seen it happen before quite a few times with other modules as well, and just never before bothered to track down why it was happening.

> Given that ActivePerl still contains some local patches to MakeMaker

For what it's worth, make them available and i'll happily work them into what we have. In fact, it would be nice if you could publish a whole library of ALL your patches to modules so i can start hunting down authors and getting them into their stuff instead of breaking things whenever i install the newest dist from CPAN. ;)

> I
> think I would prefer to keep blead as-is, and apply another local
> change to make it work for the ExtUtils::Depends stuff while mixing
> compiler versions.

Basically you're saying you'll make sure that your 5.14 AP release will contain the fixes in EUMM 6.58? I think that would be a decent solution.

> I'm sorry, you were probably waiting for me there. :(

It's fine, don't worry. I actually forgot about the whole thing while waiting too and in fact had forgotten why i was doing it in the first place until Schwern reminded me. :D

-- 
With regards,
Christian Walde

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About