develooper Front page | perl.perl5.porters | Postings from March 2011

Re: 5.14.0 and MakeMaker (Re: Call for 5.14 release blockers)

Thread Previous | Thread Next
From:
Jesse Vincent
Date:
March 25, 2011 07:52
Subject:
Re: 5.14.0 and MakeMaker (Re: Call for 5.14 release blockers)
Message ID:
20110325145226.GC9718@puppy



On Thu 24.Mar'11 at 18:54:20 -0500, Craig A. Berry wrote:
> On Mon, Mar 21, 2011 at 10:10 PM, Jesse Vincent <jesse@bestpractical.com> wrote:
> 
> Yes, we've been bad about bumping version numbers when we had to patch
> something in blead.  But, frankly, I'm afraid to try that because you
> have to touch about 30 files and if you don't do it perfectly the
> MakeMaker test suite takes revenge.

I believe we now have tests for this for everything that's blead-upstream. 

> Plus there's no way to know what
> to bump it to since you might be taking a number that will also be
> taken by the next, divergent, CPAN release.

This is the problem with "firstcome" distributions :/  We may want to
consider killing off the concept of firstcome for the core.

> I apologize for merely waving a red flag without volunteering to do
> anything, but I'm a bit overwhelmed by a pile of actual bugs that need
> fixing.

Knowing about issues is important.

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About