develooper Front page | perl.perl5.porters | Postings from March 2011

Re: MakeMaker 6.57_07 (release candidate 0)

Thread Previous
From:
Christian Walde
Date:
March 25, 2011 06:46
Subject:
Re: MakeMaker 6.57_07 (release candidate 0)
Message ID:
op.vswi65ri1fclwf@xenpad
On Fri, 25 Mar 2011 13:53:51 +0100, Christian Walde <mithaldu@yahoo.de> wrote:

> On Fri, 25 Mar 2011 04:59:38 +0100, Michael G Schwern <schwern@pobox.com> wrote:
>
>> https://github.com/Perl-Toolchain-Gang/ExtUtils-MakeMaker/tree/v6.57_07
>>
>> A new ExtUtils::MakeMaker alpha has been released, 6.57_07.  This is
>> effectively release candidate 0 for 6.58.  There has been a lot of change
>> since the last alpha and far more since the last stable.
>>
>> Please load it into your smokers and whatnot and help test it out.
>
> Quick warning: Installing this broke my 5.10 smoker.
>
> C:\Perl>perl -MCPAN::Reporter::Smoker -e "start()"
> dualvar is only available with the XS version of Scalar::Util at C:\Perl\lib/Compress/Zlib.pm line 9
> BEGIN failed--compilation aborted at C:\Perl\lib/Compress/Zlib.pm line 9.
> Compilation failed in require at C:/Perl/site/lib/CPAN/Reporter/Smoker.pm line 25.
> BEGIN failed--compilation aborted at C:/Perl/site/lib/CPAN/Reporter/Smoker.pm line 25.
> Compilation failed in require.
> BEGIN failed--compilation aborted.
>
> I'm still in the process of investigating and reproducing this problem.
>

I've reproduced this now and pinpointed the issue, ticket here: https://github.com/Perl-Toolchain-Gang/ExtUtils-MakeMaker/issues/4

For everyone else: Do not install this EUMM when your Scalar::Util is v1.22 or older; as it will break your CPAN (due to breaking Compress::Zlib).

-- 
With regards,
Christian Walde

Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About