develooper Front page | perl.perl5.porters | Postings from February 2011

Re: [rt.cpan.org #65284] Module broken with 5.13.x developmentperl versions

Thread Previous | Thread Next
From:
philippe.bruhat
Date:
February 1, 2011 14:34
Subject:
Re: [rt.cpan.org #65284] Module broken with 5.13.x developmentperl versions
Message ID:
20110201223424.GB10792@swoosh
On Tue, Feb 01, 2011 at 11:26:45PM +0100, Philippe Bruhat (BooK) wrote:
> On Mon, Jan 31, 2011 at 07:24:28PM -0800, Joshua ben Jore wrote:
> > 
> > base.pm's documented version number has been '-1, set by base.pm'. Are
> > you intending to change that?
> > 
> 
> Well, the current base.pm and VERSION don't seem to agree if one
> uses ->VERSION on a module that uses base.pm and doesn't have
> a $VERSION. Since both are distributed with the core, it seems
> the least they could do is agree.
> 
> So either base.pm pick a default version that is a better number
> than -1, or VERSION makes a special case for -1.

Oops, I missed the whole thread and replied before finding it 
back in my mailbox with plenty of informed discussion. Sorry.

-- 
 Philippe Bruhat (BooK)

 The learned man makes a mistake but once... but the truly stupid keep
 practicing until they get it right.
                                    (Moral from Groo The Wanderer #75 (Epic))

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About