develooper Front page | perl.perl5.porters | Postings from December 2010

Re: [perl #80628] [PATCH] __SUB__

Thread Previous | Thread Next
Eric Brine
December 13, 2010 09:31
Re: [perl #80628] [PATCH] __SUB__
Message ID:
On Mon, Dec 13, 2010 at 11:47 AM, Abigail <> wrote:

> > > It's more like SUPER than __FILE__ in a sense. Maybe something without
> > > dashes would be more appropriate.
> >
> I don't think so. While "SUB" is different from "sub", I'm not very keen
> to have two keywords that only differ in case. And anything else without
> underscores has the same problem as any other new keyword: possible
> clashes.

Noone suggested it should be "SUB".  I was thinking of "THIS_SUB". Someone
else also came up with that name, so I didn't mention it.

- Eric

Thread Previous | Thread Next Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at | Group listing | About