develooper Front page | perl.perl5.porters | Postings from December 2009

perl 5.10.1 Solaris 10 x86 question

From:
Stefan Parvu
Date:
December 7, 2009 05:56
Subject:
perl 5.10.1 Solaris 10 x86 question
Message ID:
Pine.SOC.4.64.0912061825010.15871@systemdatarecorder.org

Hi,

Im trying to understand whats going on here. I have built perl 5.10.1
on Solaris 10U8 x86, like this:

sh Configure -des -Dprefix=/opt/sdr/report/perl

and did install as well some CPAN modules: HTML::CalendarMonth etc.
Everything is fine.

When Im trying to add RRDs, RRDp modules
from RRDtool 1.4.2 I get the following error when running

$ perldoc perllocal:
Insecure dependency in require while running with -T switch at 
/opt/sdr/report/perl/lib/5.10.1/Pod/Perldoc.pm line 1548.

The RRDs modules installs ok and I can use it too.

This seems to be related with RRDs. If I remove the RRDs module [1]
perldoc perllocal seems to work again. Any ideas whats going on here ?
Is perl complaining about some security config of certain files ?
Permissions, user id credentials seem to be fine.

Thanks a lot,
Stefan

PS: I havent seen this in 5.10.0 Perl

[1] RRDs module
# make install
Files found in blib/arch: installing files in blib/lib into architecture 
dependent library tree
Installing 
/opt/sdr/report/perl/lib/site_perl/5.10.1/i86pc-solaris/auto/RRDs/RRDs.so
Installing 
/opt/sdr/report/perl/lib/site_perl/5.10.1/i86pc-solaris/auto/RRDs/RRDs.bs
Installing /opt/sdr/report/perl/lib/site_perl/5.10.1/i86pc-solaris/RRDs.pm
Installing /opt/sdr/report/perl/man/man3/RRDs.3



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About