develooper Front page | perl.perl5.porters | Postings from March 2009

Re: use 5.XXXYYY (was Re: ...st_birthtime...)

Thread Previous
From:
Steffen Mueller
Date:
March 2, 2009 00:00
Subject:
Re: use 5.XXXYYY (was Re: ...st_birthtime...)
Message ID:
49AAC261.6040301@sneakemail.com
Hi David,

David Golden wrote:
> I.e. replace this:
> 
>    use 5.012;
>    use strict;
>    use warnings;
>    use some_new_foo;
> 
> With just this:
> 
>    use 5.012;

as much as I sympathize with your cause, this has been discussed to no 
end on p5p a while ago. Try searching the archives for "strict by 
default" and you'll likely find my proposal, endless discussion, and two 
patches implementing it in different ways.

My impression was that the majority of people liked the idea, a minority 
didn't get it (since they were mislead to believe strict would be on for 
any code running on 5.12, use 5.012 or no), and an even smaller minority 
that simply hated it.

I've been bugging Rafael about this occasionally. The answer has always 
been: Not yet decided.

In retrospect, I think it was one of my worst mistakes posting a 
proposal to the list as it spawned an ugly thread that wasted the time 
of many smart people and myself. I should have simply discussed this on 
IRC and then do an *announcement* on p5p. ;)

My plea in this matter would be not to make this another time sink. 
Please. The verdict on the old stuff is still out.

Cheers,
Steffen

Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About