develooper Front page | perl.perl5.porters | Postings from January 2009

[PATCH] Re: 5.10.0 regressions that need fixing

Thread Previous | Thread Next
From:
Ben Morrow
Date:
January 2, 2009 15:14
Subject:
[PATCH] Re: 5.10.0 regressions that need fixing
Message ID:
20090102231335.GA12974@osiris.mauzo.dyndns.org
Quoth rgarciasuarez@gmail.com (Rafael Garcia-Suarez):
> 2008/12/30 Ben Morrow <ben@morrow.me.uk>:
> > Quoth ben@morrow.me.uk (Ben Morrow):
> >> Quoth davem@iabyn.com (Dave Mitchell):
> >> >
> >> > Subject: [perl #54956] crash on binary-or lvalue operation on qr//
> >> >
> >> >     -e 'my $re = qr/x/; $re |= "y"'
> >> >     assert failure under 5.10.0, 10-maint, bleed, but not 5.8.8
> >>
> >> I *believe* the correct fix for this is
> >
> > It turns out that produced double warnings. Patch attached, with tests.
> 
> Thanks, applied as 8c8eee8276dbc780932b841fe5183943a7117a3d

Sorry, that patch had a stupid thinko in creating a PVBM. Fix attached.

Ben


Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About