develooper Front page | perl.perl5.porters | Postings from December 2008

RE: Storable

Thread Previous | Thread Next
From:
Jan Dubois
Date:
December 15, 2008 18:21
Subject:
RE: Storable
Message ID:
002e01c95f25$02c45620$084d0260$@com
On Mon, 15 Dec 2008, Jonathan Blaine wrote:
> I'd love to upgrade perl on the production boxes, at least to 5.8.8.

Psst, go with 5.8.9 instead:

http://downloads.activestate.com/ActivePerl/Windows/5.8/ActivePerl-5.8.9.825-MSWin32-x86-288577.zip

Just don't talk about it outside P5P until Nicholas has publicly announced 5.8.9.

> Can you tell me, in general (i.e. I'm not going to blame you if it fails)  if
> I ZIP up/backup  the perl installation as it is now, install 5.8.8, and
> encounter problems with existing scripts, can I simply replace the perl
> directory with the backed-up version and be back to functional?  I remember
> being told that long ago (5.6.x) but I've never had the occasion to try it,
> and heaven knows things may have changed by now.

No, this should still all work.  For extra caution use the installer.bat from
the ZIP file I linked above instead of using the MSI installer.  That way you
can decline all changes to registry, environment variables and web server setup,
so you don't modify anything except for the target installation directory.

Cheers,
-Jan


Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About