develooper Front page | perl.perl5.porters | Postings from November 2008

Re: 5.8.9 RC1

Thread Previous | Thread Next
From:
Nicholas Clark
Date:
November 17, 2008 05:29
Subject:
Re: 5.8.9 RC1
Message ID:
20081117132921.GQ49335@plum.flirble.org
On Sun, Nov 16, 2008 at 02:21:57AM +0100, Slaven Rezic wrote:
> Nicholas Clark <nick@ccl4.org> writes:
> 
> >
> > Currently it's at
> >
> >     http://www.ccl4.org/~nick/P/perl-5.8.9-RC1.tar.bz2
> >
> 
> I finished the CPAN smoking:

Thanks.

> Crypt-SecurID-0.04 and XML-Xerces-2.7.0-0 cannot be build with 5.8.9 RC1
> because of
> http://groups.google.com/group/perl.perl5.porters/browse_thread/thread/21616e82d46f7999
> RT tickets for both distributions exist:
> http://rt.cpan.org/Ticket/Display.html?id=40942
> http://rt.cpan.org/Ticket/Display.html?id=40956

They are source build failures, and they're not silent failures. Anyone who
bravely* upgrades 5.8.8 (or earlier) to 5.8.9 without testing isn't suddenly
going to find that their running system breaks. So I'm happy.

> Tie-Array-FileWriter-0.1 fails now because of change 32542 (and of the
> integrated changes it is very probably the change 31473). A sample
> fail report may be seen here:
> http://www.nntp.perl.org/group/perl.cpan.testers/2008/11/msg2625288.html

I've noted the bug fix that calls this in perl589delta.

> Devel-SmallProf-2.02 probably looks to deep into the internals. Here's
> the RT ticket about its failure with perl 5.8.9:
> http://rt.cpan.org/Ticket/Display.html?id=40902 

I've fixed that regression.

Nicholas Clark

* in the sense of "that is a brave decision, Minister"

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About