develooper Front page | perl.perl5.porters | Postings from November 2008

RE: 5.8.9 RC1

Thread Previous | Thread Next
From:
Konovalov, Vadim ** CTR **
Date:
November 11, 2008 02:02
Subject:
RE: 5.8.9 RC1
Message ID:
D16F05D0CAAA234BA2B753B80DE6100DC6961D@DEEXC1U02.de.lucent.com
> Currently it's at
> 
>     http://www.ccl4.org/~nick/P/perl-5.8.9-RC1.tar.bz2
> 
> Please don't publicise that URL outside p5p  - instead
> 
>   
> ftp://ftp.cpan.org/pub/CPAN/authors/id/N/NW/NWCLARK/perl-5.8.9
> -RC1.tar.bz2
> 
> once it's had time to propagate to CPAN's mirrors.

very small problem.

I happen not to have "localhost" entry in /etc/hosts and therefore got
failing test:


Failed 1 test out of 1108, 99.91% okay.
        ../lib/Net/hostent.t
### Since not all tests were successful, you may want to run some of
### them individually and examine any diagnostic messages they produce.
### See the INSTALL document's section on "make test".
### You have a good chance to get more information by running
###   ./perl harness
### in the 't' directory since most (>=80%) of the tests succeeded.
### You may have to set your dynamic library search path,
### LD_LIBRARY_PATH, to point to the build directory:
###   setenv LD_LIBRARY_PATH `pwd`:$LD_LIBRARY_PATH; cd t; ./perl
harness
###   LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH; export LD_LIBRARY_PATH; cd
t; ./perl harness
###   export LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH; cd t; ./perl
harness
### for csh-style shells, like tcsh; or for traditional/modern
### Bourne-style shells, like bash, ksh, and zsh, respectively.
u=3.50  s=3.07  cu=193.45  cs=84.60  scripts=1108  tests=133369
make[2]: *** [_test_tty] Error 1
make[2]: Leaving directory `/home/vad/Personal/perl-dev/perl-5.8.9-RC1'
make[1]: *** [_test] Error 2
make[1]: Leaving directory `/home/vad/Personal/perl-dev/perl-5.8.9-RC1'
make: *** [test] Error 2



running it separatedly gives me a wrong guess on my problem:

coli perl-5.8.9-RC1 # ./perl ./lib/Net/hostent.t
1..7
ok 1 - use Net::hostent;
not ok 2 - gethost('localhost')
#   Failed test 'gethost('localhost')'
#   at ./lib/Net/hostent.t line 36.
# Can't continue without working gethost:
# Looks like you planned 7 tests but only ran 2.
# Looks like you failed 1 test of 2 run.
# Looks like your test died just after 2.


I do have working gethost, although do not have "localhost" entry.

When I added "localhost" all became ok:

coli perl-5.8.9-RC1 # ./perl ./lib/Net/hostent.t
1..7
ok 1 - use Net::hostent;
ok 2 - gethost('localhost')
ok 3 - addr from gethost
ok 4 - gethostbyaddr('127.0.0.1')
ok 5 - addr from gethostbyaddr
# name = localhost, aliases =
ok 6
ok 7
# localhost


Best regards,
Vadim.

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About