develooper Front page | perl.perl5.porters | Postings from September 2008

Re: Perl-5.8.6 or Perl-5.8.5 Install/Build process on AIX 5.3 Make problem make: 1254-002 Cannot find a rule to create target <command-line> from dependencies. Stop.

Thread Previous | Thread Next
From:
Arshad
Date:
September 1, 2008 04:27
Subject:
Re: Perl-5.8.6 or Perl-5.8.5 Install/Build process on AIX 5.3 Make problem make: 1254-002 Cannot find a rule to create target <command-line> from dependencies. Stop.
Message ID:
5c63c0bb0809010102g3530e3dfh6a06884741db795c@mail.gmail.com
Hi,
    Can u tell me..what exactly do i add to makedepend.SH still running into
issues if i add

@@ -167,6 +167,7 @@ for file in `$cat .clist`; do
            -e '/^#.*<builtin>/d' \
            -e '/^#.*<built-in>/d' \
            -e '/^#.*<command line>/d' \
+            -e '/^#.*<command-line>/d' \
           -e '/^#.*"-"/d' \
           -e '/: file path prefix .* never used$/d' \
           -e 's#\.[0-9][0-9]*\.c#'"$file.c#" \


please give me..syntax of the line i have to add...still getting errs please
help...


I am using perl-5.8.6 DBI-1.50 and DBD-Oracle.1.61 becacuse i want
DBD-Oracle to work with older version of databases also....


my Question... is will perl-5.8.8 or 5.10.0 DBI-1.607 and DBD-Oracle-1.22
works for older version of oracle 8 and 9i?

what i want from this install is, i want my perl scripts to run and connect
to database... all versions..of DB oracle 8, 9 and 10g.


On Mon, Sep 1, 2008 at 12:23 PM, H.Merijn Brand <h.m.brand@xs4all.nl> wrote:

> On Mon, 1 Sep 2008 12:14:16 +0530, Arshad <arshad.moin@famsoft.com>
> wrote:
>
> > Hello All,
> >               I need perl version installed on AIX 5.3 box with DBI-1.50
> and
> > DBD-Oracle-1.16 any suggestions on this any install documents will
> help....
>
> That is no explanation why you want to install *OLD* versions.
>
> I already posted a patch that will help you to finish builds, but I
> stongly suggest to use newer versions of the truth:
>
> perl-5.8.8 or 5.10.0
> DBI-1.607
> DBD-Oracle-1.22
>
> > Thanks... for replying
> >
> > On Mon, Sep 1, 2008 at 12:01 PM, H.Merijn Brand <h.m.brand@xs4all.nl>
> wrote:
> >
> > > On Mon, 1 Sep 2008 04:40:43 +0530, "Mohammed Arshad"
> > > <arshad.moin@famsoft.com> wrote:
> > >
> > > > Hello all,
> > > >
> > > >                 I am trying to build perl-5.8.6.tar.gz
> DBI-1.50.tar.gz
> > > and
> > > > DBD-Oracle-1.16.tar.gz on AIX 5.3.0.0 downloaded from cpan.org I am
> > > trying
> > > > to build the software from the source and running into issues.
> > >
> > > Why an old combination like that?
> > > perl-5.8.6 is from November 2004. The most recent stable version is
> > > either 5.8.8 (Jan 2006) or 5.10.0 (Dec 2007).
> > > DBI-1.50 is from back in Dec 2005. Current is DBI-1.607
> > >
> > > I'm not surprised at all that you run into trouble with 5.8.6.
> > >
> > > > What steps I ran
> > > >
> > > > Install perl-5.8.6(downloaded perl source code from capn.org )
> > > >
> > > > -bash-3.00# oslevel
> > > > 5.3.0.0
> > >
> > > Next time, use 'oslevel -r', so we also see the patch level
> > >
> > > > -bash-3.00# lslpp -l | grep 'bos.rte '
> > > >   bos.rte          5.3.7.0   COMMITTED  Base Operating System
> Runtime
> > > >   bos.rte          5.3.0.60  COMMITTED  Base Operating System
> Runtime
> > > > -bash-3.00# lslpp -l | egrep "syscalls|libm"
> > > >   bos.adt.libm     5.3.7.0   COMMITTED  Base Application Development
> > > >   bos.adt.syscalls 5.3.7.0   COMMITTED  System Calls Application
> > > > -bash-3.00# gcc -v
> > > > gcc version 4.2.0
> > > > -bash-3.00#
> > > >
> > > > I have GCC and I am trying to build perl-5.8.6 using gcc and running
> into
> > > > issues..
> > > >
> > > > #sh Configure -Dcc=gcc
> > > >
> > > > #configure.sh success.png
> > >
> > > The way you include images in this post is counter-productive. Most of
> > > us here use ASCII mail clients, and including images of ASCII-terminal
> > > screenshots is kinda useless.
> > >
> > > The first, and main problem is the the missing filter for
> > > <command-line>, which has been fixed when gcc-4.2 came out, so using
> > > 5.8.8 or 5.10.0 should fix that. If you *have to* use 5.8.6, add that
> > > line to makedepend.SH
> > >
> > > --- makedepend.SH.org   2008-08-26 13:48:21 +0200
> > > +++ makedepend.SH       2008-08-26 13:48:22 +0200
> > > @@ -167,6 +167,7 @@ for file in `$cat .clist`; do
> > >             -e '/^#.*<builtin>/d' \
> > >             -e '/^#.*<built-in>/d' \
> > >             -e '/^#.*<command line>/d' \
> > > +            -e '/^#.*<command-line>/d' \
> > >            -e '/^#.*"-"/d' \
> > >            -e '/: file path prefix .* never used$/d' \
> > >            -e 's#\.[0-9][0-9]*\.c#'"$file.c#" \
>
>
> --
> H.Merijn Brand          Amsterdam Perl Mongers  http://amsterdam.pm.org/
> using & porting perl 5.6.2, 5.8.x, 5.10.x, 5.11.x on HP-UX 10.20, 11.00,
> 11.11, 11.23, and 11.31, SuSE 10.1, 10.2, and 10.3, AIX 5.2, and Cygwin.
> http://mirrors.develooper.com/hpux/           http://www.test-smoke.org/
> http://qa.perl.org      http://www.goldmark.org/jeff/stupid-disclaimers/
>



-- 
Thanks and Regards
Mohammed Arshad
Software Engineer
FAMSOFT.
www.famsoft.com

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About