develooper Front page | perl.perl5.porters | Postings from September 2008

Re: Perl-5.8.6 or Perl-5.8.5 Install/Build process on AIX 5.3 Makeproblem make: 1254-002 Cannot find a rule to create target <command-line>from dependencies. Stop.

Thread Previous | Thread Next
From:
H.Merijn Brand
Date:
September 1, 2008 02:35
Subject:
Re: Perl-5.8.6 or Perl-5.8.5 Install/Build process on AIX 5.3 Makeproblem make: 1254-002 Cannot find a rule to create target <command-line>from dependencies. Stop.
Message ID:
20080901113502.6d126f56@pc09.procura.nl
On Mon, 1 Sep 2008 13:32:59 +0530, Arshad <arshad.moin@famsoft.com>
wrote:

> Hi,
>     Can u tell me..what exactly do i add to makedepend.SH still running into
> issues if i add
> 
> @@ -167,6 +167,7 @@ for file in `$cat .clist`; do
>             -e '/^#.*<builtin>/d' \
>             -e '/^#.*<built-in>/d' \
>             -e '/^#.*<command line>/d' \
> +            -e '/^#.*<command-line>/d' \
>            -e '/^#.*"-"/d' \
>            -e '/: file path prefix .* never used$/d' \
>            -e 's#\.[0-9][0-9]*\.c#'"$file.c#" \
> 
> 
> please give me..syntax of the line i have to add...still getting errs please
> help...

What is unclear about the above patch?

> I am using perl-5.8.6 DBI-1.50 and DBD-Oracle.1.61 becacuse i want
> DBD-Oracle to work with older version of databases also....

Define 'older' I have DBD-Oracle-1.19 still working on Oracle-8.1.7
If you need support for older Oracle, you should only use an older
DBD-Oracle, but still use recent perl and DBI. They have nothing to do
with the database backend.

> my Question... is will perl-5.8.8 or 5.10.0 DBI-1.607 and DBD-Oracle-1.22
> works for older version of oracle 8 and 9i?

DBD-Oracle-1.19 is the last to officially support Oracle 8, but it
would not be unthinkable that it is possible to get 1.22 working on
archaic releases of Oracle, though I personally wouldn't try.

perl and DBI have, as I said, nothing to do with the database backend

> what i want from this install is, i want my perl scripts to run and connect
> to database... all versions..of DB oracle 8, 9 and 10g.

Install DBD::Oracle-1.19 for Oracle 8 and DBD-Oracle-1.22 for the other
two. You cannot install DBD-Oracle to support multiple database
versions in one single install, as they link to different libraries.

If you want to support ALL your Oracle databases from one single
install, you will have to install the most recent Oracle Instant Client
and link to that, instead of to the database libraries itself.

Don't expect any help on this list if you venture into that path.
This is the perl5 core development ML, not the DBD ML

> On Mon, Sep 1, 2008 at 12:23 PM, H.Merijn Brand <h.m.brand@xs4all.nl> wrote:
> 
> > On Mon, 1 Sep 2008 12:14:16 +0530, Arshad <arshad.moin@famsoft.com>
> > wrote:
> >
> > > Hello All,
> > >   I need perl version installed on AIX 5.3 box with DBI-1.50 and
> > > DBD-Oracle-1.16 any suggestions on this any install documents will
> > > help....
> >
> > That is no explanation why you want to install *OLD* versions.
> >
> > I already posted a patch that will help you to finish builds, but I
> > stongly suggest to use newer versions of the truth:
> >
> > perl-5.8.8 or 5.10.0
> > DBI-1.607
> > DBD-Oracle-1.22

-- 
H.Merijn Brand          Amsterdam Perl Mongers  http://amsterdam.pm.org/
using & porting perl 5.6.2, 5.8.x, 5.10.x, 5.11.x on HP-UX 10.20, 11.00,
11.11, 11.23, and 11.31, SuSE 10.1, 10.2, and 10.3, AIX 5.2, and Cygwin.
http://mirrors.develooper.com/hpux/           http://www.test-smoke.org/
http://qa.perl.org      http://www.goldmark.org/jeff/stupid-disclaimers/

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About