Johan Vromans wrote: > [Quoting Roland Giersig, on August 4 2008, 12:23, in "Re: Fighting the Goo"] >> I was thinking along the lines: >> >> package Iterator::Diamond; >> @ISA = qw(Iterator::Files); > > Yes, that's what I'm thinking, too. Well, come to think of, maybe not ISA Iterator::Files, but 'use Iterator::Files' instead, as the interface should be completely hidden behind ARGV and friends. > BTW, would Iterator::FileList be a better name? I don't think so, because you are mainly iterating over file content (lines), not file(name)s per se. So Iterator::FileListContent would be more appropriate, but too long for us lazy typists... ;-) Iterator::Lines Iterator::FileListLines Iterator::Slurpy (I like that one, needs a cute mascot though... ;o)) hmm, it doesn't need to be lines, so maybe Iterator::Chunks Iterator::FileChunks Any other brainstorms?