develooper Front page | perl.perl5.porters | Postings from May 2008

Re: alias for %+

Thread Previous
May 21, 2008 07:47
Re: alias for %+
Message ID:
2008/5/21 Amir E. Aharoni <>:
> The %+ variable, which is new in 5.10 if i understand correctly,
> doesn't have a proper alias for
> %LAST_PAREN_MATCH works, because it is defined in as an
> alias for *+. But it's not an intuitive name and it wasn't intended
> for this and it's not documented in perlvar.
> Is there anyone who decides about the names of aliases in,
> or can i just be bold, make up a name and send a patch? I thought that
> %NAMED_CAPTURE would be appropriate.
> This is my first message on this list, so if it's a stupid question or
> the wrong list, feel free to bite me.

No no. You wont get bitten on this list so long as you stay around
from Unicode related issues..... (context humour, if you dont get it
dont worry, just read the p5p archives :-)

I dont think thats a bad name. But dont forget about %- at the same
time. Maybe NAMED_CAPTURE and NAMED_CAPTURE_LIST for %+ and %-


perl -Mre=debug -e "/just|another|perl|hacker/"

Thread Previous Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at | Group listing | About