develooper Front page | perl.perl5.porters | Postings from February 2008

Re: Assistance with IPC modules and perl 5.10

Thread Previous | Thread Next
From:
Tels
Date:
February 18, 2008 08:21
Subject:
Re: Assistance with IPC modules and perl 5.10
Message ID:
200802181721.06447@bloodgate.com
On Monday 18 February 2008 03:54:27 Tom "spot" Callaway wrote:
> perl-Heap
> perl-Graph

Why would these two depend on:

> Thus, IPC::ShareLite and IPC::SharedCache are pivotal to the perl

?

Here is the META.yml for Heap:

##############################
# http://module-build.sourceforge.net/META-spec.html
#XXXXXXX This is a prototype!!!  It will change in the future!!! XXXXX#
name:         Heap
version:      0.80
version_from: lib/Heap.pm
installdirs:  site
requires:
    Test::Simple:                  0.45

distribution_type: module
generated_by: ExtUtils::MakeMaker version 6.17
################################

It only depends on Test::Simple[0]. Test::Simple requires Test::Harness. 
Test::Harness requires File::Spec. Which is in core, so the chain ends 
here. So, what why are you getting different results?

best wishes,

Tels

0. and I bet it does so only for the testing, not for the actual build 
or install - curse incomplete META.yml files written by outdated tools 
or manually...


-- 
 Signed on Mon Feb 18 17:17:44 2008 with key 0x93B84C15.
 View my photo gallery: http://bloodgate.com/photos
 PGP key on http://bloodgate.com/tels.asc or per email.

 "The UAC is making safer worlds through superior firepower."


Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About