develooper Front page | perl.perl5.porters | Postings from October 2007

Re: configure failed in tru64

Thread Previous | Thread Next
From:
Xiao Yafeng
Date:
October 26, 2007 19:06
Subject:
Re: configure failed in tru64
Message ID:
309b71990710261905r56461647t2f47697cede47854@mail.gmail.com
Sorry for not affording too many info about system due to my vocation. below
is what I know:
which cc
/usr/bin/cc (it is a link file from /usr/lib/cmplrs/cc/drivers)
which ld
/usr/bin/ld

sizer -V
Digital UNIX V4.0G (Rev. 1530)

gxtms#> env
TERM=ansi
GWSOURCE=telnet
HOME=/
SHELL=/bin/csh
USER=root
LOGNAME=root
PATH=/sbin:/usr/sbin:/usr/bin:/usr/bin/X11
SHLVL=1
I18NPATH=/usr/i18n
EDITMODE=emacs

tru64 don't support uname command

Thanks!

On 10/27/07, Jarkko Hietaniemi <jhi@iki.fi> wrote:
>
> Xiao Yafeng wrote:
> > I've found I can't compile any perl version ( including perl 5.6.2 perl
> > 5.8.8 and perl 5.95) in my system.
> > I report this to bugperl:
> > http://rt.perl.org/rt3//Public/Bug/Display.html?id=46729
> >
> > But strangely,  If I comment out no_ansi_alias statement in dec_osf.sh,
> make
> > depend will throw below error:
> > ./makedepend: makefile: cannot open
> > echo Makefile.SH cflags.SH config_h.SH makeaperl.SH makedepend.SH
> > makedir.SH my
> > config.SH writemain.SH pod/Makefile.SH | tr ' ' '\n' >.shlist
> > Updating makefile...
> > cp: makefile: No such file or directory
> > ........
> > ........
> > echo Makefile.SH cflags.SH | tr ' ' '\n' >.shlist
> > Updating makefile...
> > Now you must run 'make'.
> >
> >
> > I don't know whether or not is relative to comment
> out  no_ansi_alias  flag.
>
> Please show us the outputs of the following commands:
>
> which cc
> which ld
> cc -V
> ld -V
> sizer -v
> uname -r
> echo $PATH
>
> >>
> >>
> >
>
>

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About