develooper Front page | perl.perl5.porters | Postings from March 2007

Re: $Win32::VERSION problem

Thread Previous | Thread Next
From:
Yitzchak Scott-Thoennes
Date:
March 6, 2007 10:53
Subject:
Re: $Win32::VERSION problem
Message ID:
13947.68.166.55.187.1173207182.squirrel@68.166.55.187
(resending this with a nonblank subject)

On Wed, Feb 28, 2007 at 01:22:26PM -0800, Jan Dubois wrote:
> On Wed, 28 Feb 2007, Jerry D. Hedden wrote:
> > Jan Dubois wrote:
> > > One thing we could do, at least for maint, is duplicate the old code
> > > from win32/win32.c in Win32CORE and remove the version check for
> > > Win32.
> > >
> > > I can make a patch for this later this week, but I don't think it
> > > should end up in blead (except maybe for testing), because this would
> > > be essentially dead bloat.
> >
> > Yitzchak Scott-Thoennes wrote:
> > > I'd rather not have this even in maint - there really doesn't seem to
> > > any reason to do it. Is there anything I can do to help get new
> > > libwin32 and Win32 distributions out?
>
> I've been waiting for more feedback on how people feel about this
> situation (I've also had no time to actually *do* anything yet).
>
> I'll try to do the releases on the weekend,

How's it going? :)

> and also post my plans for future libwin32 maintenance on the libwin32
> mailing list (I essentially want to release modules separately and not as
> this big bundle, as having a big distribution effectively prevents me from
> making new releases because I never find enough time in one chunk to apply
> all the outstanding patches to all the modules).

Some of them are already in separate distributions.

> > Why not have this in maint? Currently, the Cygwin distribution installs
> > a copy of Win32CORE into the Perl distribution before compiling. Adding
> > the Win32 stuff to maint would eliminate this.
>
> I think Yitzchak meant he doesn't want the fallback code in maint and
> thinks it is acceptable that you could only build the latest libwin32 I
> think Yitzchak meant he doesn't want the fallback code in maint and thinks
> it is acceptable that you could only build the latest libwin32 release
> with 5.8.9 but not earlier ones.

Correct.

> I've been waiting to hear more feedback like this, as I don't have a set
> opinion on this issue yet.
>
> If Nicholas decides that maint doesn't need the fallback bloat, then I
> won't bother with making a patch. :)

So, Nicholas, are you comfortable putting this in maint yet?  If not, what
are your remaining concerns?


Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About