develooper Front page | perl.perl5.porters | Postings from April 2006

Re: podlators/Pod::Simple backwards compatibility (was: Re: [PATCH] 5.8.8: Debian patches)

Thread Previous | Thread Next
From:
Nicholas Clark
Date:
April 27, 2006 09:54
Subject:
Re: podlators/Pod::Simple backwards compatibility (was: Re: [PATCH] 5.8.8: Debian patches)
Message ID:
20060427165405.GH45236@plum.flirble.org
On Sun, Feb 19, 2006 at 10:09:24PM -0800, Yitzchak Scott-Thoennes wrote:

> I poked at this a little more; here are some Pod::Simple changes that
> fix a few differences from what Pod::Parser did: allow any kind of
> object that has a getline() method, prevent output filenames beginning
> &,>, from being special, preserve special STDERR handling.  Also
> specify INSTALLDIRS=perl in Makefile.PL when appropriate.
> 
> There remain a few Pod::Parser oddities not supported:
> 
> parse_from_file and parse_from_filehandle used to take an optional
> initial hashref specifying options; the only one I actually saw code
> for was {-cutting=>0} which would make the parser assume the file
> starts with pod, not with perl code.
> 
> There was code to allow parse_from_file/filehandle to be recursively
> called from a handler that would make the parser continue with the new
> file and then switch back to the original file, but preserve the same
> output file unless a new output file were specified.  I can't offhand
> think of any use at all for this, much less one relevant to podlators.
> 
> Pod::Parser would close the input or output file if it opened it itself
> rather than being passed a handle.

Did anything come of this?

I was wondering what subtle but known differences exist between the behaviour
of the POD modules in 5.8.8, and those in blead.

Nicholas Clark

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About