develooper Front page | perl.perl5.porters | Postings from September 2005

CORE::GLOBAL::require and "require 5" broken.

Thread Next
From:
Michael G Schwern
Date:
September 26, 2005 14:39
Subject:
CORE::GLOBAL::require and "require 5" broken.
Message ID:
20050926213951.GA12467@windhund.schwern.org
$ perl5.8.6 -wle 'BEGIN { *CORE::GLOBAL::require = sub { print "In CORE::GLOBAL.\n";  CORE::require($_[0]) } }  require 5'
In CORE::GLOBAL.

$ bleadperl -wle 'require 5'

$ bleadperl -wle 'BEGIN { *CORE::GLOBAL::require = sub { print "In CORE::GLOBAL.\n";  CORE::require($_[0]) } }  require 5'
In CORE::GLOBAL.

Perls since v5.0.0 too modern--this is v5.9.3, stopped at -e line 1.

Hurrrr, what?


-- 
Michael G Schwern     schwern@pobox.com     http://www.pobox.com/~schwern
Life is like a sewer - what you get out of it depends on what you put into it.
    - Tom Lehrer

Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About