develooper Front page | perl.perl5.porters | Postings from July 2005

[perl #36524] problems running DBI and installing Bundle::DBI

Thread Next
From:
sleepy groups
Date:
July 13, 2005 03:43
Subject:
[perl #36524] problems running DBI and installing Bundle::DBI
Message ID:
rt-3.0.11-36524-117148.17.9392175520165@perl.org
# New Ticket Created by  sleepy groups 
# Please include the string:  [perl #36524]
# in the subject line of all future correspondence about this issue. 
# <URL: https://rt.perl.org/rt3/Ticket/Display.html?id=36524 >


Hello,

*Synopsis:* 
I am using Fedora Core 4 and I am trying to download Bundle::DBI from CPAN 
using the PPM prompt. I can download DBI with no problem, but I have 
problems downloading Bundle:DBI. I don't care what downloads, but I just 
want DBI to work. The error logs are listed below.


*Background:*
I found this error message on 
http://www.nntp.perl.org/group/perl.cpan.testers/156712 
which is the same error message that I got
> so I decided to write and ask if you can help me with the same problem.
> So I went on some newsgroups and showed them my error messages (it
> was with "Make"). Actually they couldn't solve my problems so I think it 
might not be a problem with "Make".


*Issue:*
I installed DBI and DBD::CSV with no problems and got the following typing 
the command:
>
> perl -MCPAN -e 'install DBI'
>
> Writing Makefile for DBD::CSV
> cp lib/Bundle/DBD/CSV.pm blib/lib/Bundle/DBD/CSV.pm
> cp lib/DBD/CSV.pm blib/lib/DBD/CSV.pm
> Manifying blib/man3/DBD::CSV.3pm
> Manifying blib/man3/Bundle::DBD::CSV.3pm
> -=-=-=-=-=-=-=-=-=-=-=-=-
> * /usr/bin/make -- OK
*> -=-=-=-=-=-=--=-=-=--=-=-=
> Running make test
>
............(shortened).............

> /usr/bin/make test -- OK
>
> Running make install
> Installing /usr/share/man/man3/DBD::CSV.3pm
> Installing /usr/share/man/man3/Bundle::DBD::CSV.3pm
> Writing /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi/auto/
> DBD/CSV/.packlist
> Appending installation info to /usr/lib/perl5/5.8.1/i386-linux-thread-
> multi/perllocal.pod
>
> /usr/bin/make install -- OK
>

----------------------------------------------------------------

> but still when I try to run a CSV DBI called listcsv.pl I get the
> following errors:

> install_driver(CSV) failed: Can't locate loadable object for module
> DBD::CSV in @INC (@INC contains: /usr/lib/perl5/5.8.1/i386-linux-
> thread-multi /usr/lib/perl5/5.8.1 /usr/lib/perl5/vendor_perl/5.8.1 /
> usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/
> perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl /usr/lib/
> perl5/5.8.1/i386-linux-thread-multi /usr/lib/perl5/5.8.1 .) at (eval
> 1) line 3
> Compilation failed in require at (eval 1) line 3.
> Perhaps a module that DBD::CSV requires hasn't been fully installed
>


> -----------------------------------------------------------
> I thought all you need is DBI and
> DBD::CSV to handle DBI database scripts. So I went back and tried to
> install the whole bundle, Bundle::DBI, from CPAN:

> perl -MCPAN -e 'install Bundle::DBI
>
> and got the error:
> /usr/bin/make -- NOT OK

>
> BUT beforethat, I saw this error:
>
> running make test
> PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e"
> "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
> t/base..........ok
> t/config........ok
> t/fork..........ok
>
> t/forkm.........make: *** [test_dynamic] Interrupt
> /usr/bin/make test -- NOT OK
>
> Running make install
> make test had returned bad status, won't install without force
>
> So
> 1. Does anyone know why Make worked for DBI installation and not
> Bundle::DBI?
> 2. Does anyone know what tforkm is and what that might indicate if it
> gives an error during install?
>
> Thanks!
-Steve

Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About